Web Portal delays
Resolved
This incident has been resolved.
Posted Oct 02, 2019 - 11:45 UTC
Investigating
Our Web Portal infrastructure is suffering slow downs.
Posted Oct 02, 2019 - 10:09 UTC