Web Portal delays
Resolved
This incident has been resolved.
Posted about 1 month ago. Nov 16, 2018 - 15:20 UTC
Investigating
Our Web Portal infrastructure is suffering slow downs.
Posted about 1 month ago. Nov 16, 2018 - 14:49 UTC