Web Portal delays
Resolved
This incident has been resolved.
Posted Jan 05, 2020 - 00:31 UTC
Investigating
Our Web Portal infrastructure is suffering slow downs.
Posted Jan 05, 2020 - 00:23 UTC