Web Portal delays
Resolved
This incident has been resolved.
Posted Feb 06, 2020 - 14:12 UTC
Investigating
Our Web Portal infrastructure is suffering slow downs.
Posted Feb 06, 2020 - 14:03 UTC