Web Portal delays
Resolved
This incident has been resolved.
Posted Oct 16, 2019 - 22:16 UTC
Investigating
Our Web Portal infrastructure is suffering slow downs.
Posted Oct 16, 2019 - 21:48 UTC