API Servers Response Delays
Resolved
This incident has been resolved.
Posted 6 days ago. Jun 14, 2018 - 14:53 UTC
Investigating
Our API servers infrastructure is suffering slow down in response time
Posted 14 days ago. Jun 06, 2018 - 10:59 UTC