Web Portal delays
Resolved
This incident has been resolved.
Posted 2 months ago. Jul 12, 2018 - 13:00 UTC
Investigating
Our Web Portal infrastructure is suffering slow downs.
Posted 2 months ago. Jul 12, 2018 - 11:06 UTC