Web Portal delays
Resolved
This incident has been resolved.
Posted 7 days ago. Mar 12, 2019 - 07:31 UTC
Investigating
Our Web Portal infrastructure is suffering slow downs.
Posted 7 days ago. Mar 12, 2019 - 07:23 UTC