Web Portal delays
Resolved
This incident has been resolved.
Posted 5 days ago. Sep 12, 2019 - 13:16 UTC
Investigating
Our Web Portal infrastructure is suffering slow downs.
Posted 5 days ago. Sep 12, 2019 - 13:13 UTC