Web Portal delays
Resolved
This incident has been resolved.
Posted Mar 19, 2020 - 22:31 UTC
Investigating
Our Web Portal infrastructure is suffering slow downs.
Posted Mar 19, 2020 - 22:24 UTC