Web Portal delays
Resolved
This incident has been resolved.
Posted Mar 21, 2020 - 01:51 UTC
Investigating
Our Web Portal infrastructure is suffering slow downs.
Posted Mar 21, 2020 - 01:42 UTC