Web Portal delays
Resolved
This incident has been resolved.
Posted Mar 14, 2020 - 19:22 UTC
Investigating
Our Web Portal infrastructure is suffering slow downs.
Posted Mar 14, 2020 - 19:13 UTC