Web Portal delays
Resolved
This incident has been resolved.
Posted Oct 21, 2019 - 19:48 UTC
Investigating
Our Web Portal infrastructure is suffering slow downs.
Posted Oct 21, 2019 - 19:33 UTC