Web Portal delays
Resolved
This incident has been resolved.
Posted Oct 11, 2019 - 23:11 UTC
Investigating
Our Web Portal infrastructure is suffering slow downs.
Posted Oct 11, 2019 - 22:58 UTC