Web Portal delays
Resolved
This incident has been resolved.
Posted Oct 11, 2019 - 20:26 UTC
Investigating
Our Web Portal infrastructure is suffering slow downs.
Posted Oct 11, 2019 - 20:22 UTC