Web Portal delays
Resolved
This incident has been resolved.
Posted Mar 18, 2020 - 18:41 UTC
Investigating
Our Web Portal infrastructure is suffering slow downs.
Posted Mar 18, 2020 - 18:23 UTC