Web Portal delays
Resolved
This incident has been resolved.
Posted 2 months ago. Aug 14, 2019 - 18:56 UTC
Investigating
Our Web Portal infrastructure is suffering slow downs.
Posted 2 months ago. Aug 14, 2019 - 18:38 UTC