Web Portal delays
Resolved
This incident has been resolved.
Posted 8 days ago. Sep 10, 2018 - 08:53 UTC
Investigating
Our Web Portal infrastructure is suffering slow downs.
Posted 8 days ago. Sep 10, 2018 - 08:53 UTC