Web Portal delays
Resolved
This incident has been resolved.
Posted Nov 20, 2019 - 06:48 UTC
Investigating
Our Web Portal infrastructure is suffering slow downs.
Posted Nov 20, 2019 - 06:42 UTC