Web Portal delays
Resolved
This incident has been resolved.
Posted Jan 31, 2020 - 18:51 UTC
Investigating
Our Web Portal infrastructure is suffering slow downs.
Posted Jan 31, 2020 - 18:43 UTC