Web Portal delays
Resolved
This incident has been resolved.
Posted 12 days ago. Feb 04, 2019 - 13:39 UTC
Investigating
Our Web Portal infrastructure is suffering slow downs.
Posted 12 days ago. Feb 04, 2019 - 13:30 UTC