Web Portal delays
Resolved
This incident has been resolved.
Posted 7 days ago. Sep 10, 2019 - 01:59 UTC
Investigating
Our Web Portal infrastructure is suffering slow downs.
Posted 7 days ago. Sep 10, 2019 - 01:59 UTC