Web Portal delays
Resolved
This incident has been resolved.
Posted Mar 15, 2020 - 19:51 UTC
Investigating
Our Web Portal infrastructure is suffering slow downs.
Posted Mar 15, 2020 - 19:43 UTC